ElementWorksetFilter Constructor (WorksetId, Boolean)


Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public ElementWorksetFilter(
	WorksetId worksetId,
	bool inverted
)
Visual Basic
Public Sub New ( _
	worksetId As WorksetId, _
	inverted As Boolean _
)
Visual C++
public:
ElementWorksetFilter(
	WorksetId^ worksetId, 
	bool inverted
)

Parameters

worksetId
Type: Autodesk.Revit.DBWorksetId
The workset id to match.
inverted
Type: SystemBoolean
True if the filter should match all elements which are not in the given workset.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also