Create Method


Creates an object representing element or subelement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static Subelement Create(
	Document aDoc,
	Reference reference
)
Visual Basic
Public Shared Function Create ( _
	aDoc As Document, _
	reference As Reference _
) As Subelement
Visual C++
public:
static Subelement^ Create(
	Document^ aDoc, 
	Reference^ reference
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document.
reference
Type: Autodesk.Revit.DBReference
The reference that identifies element or subelement.

Return Value

The newly created subelement.

Remarks

If %reference% points to linked document:
  • The GetReference method of the newly created subelement will return the local reference in the linked document.
  • The Document property of the newly created subelement will return the linked document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException reference does not identify a valid element or subelement.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also