Subelement Create Method |
Creates an object representing element or subelement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- aDoc Document
- The document.
- reference Reference
- The reference that identifies element or subelement.
Return Value
SubelementThe newly created subelement.

Exception | Condition |
---|---|
ArgumentException | reference does not identify a valid element or subelement. |
ArgumentNullException | A non-optional argument was null |

If %reference% points to linked document:
- The GetReference method of the newly created subelement will return the local reference in the linked document.
- The Document property of the newly created subelement will return the linked document.