Create Method


Creates a new instance of PathReinSpanSymbol in the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static PathReinSpanSymbol Create(
	Document document,
	ElementId viewId,
	LinkElementId hostId,
	XYZ point,
	ElementId symbolId
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	viewId As ElementId, _
	hostId As LinkElementId, _
	point As XYZ, _
	symbolId As ElementId _
) As PathReinSpanSymbol
Visual C++
public:
static PathReinSpanSymbol^ Create(
	Document^ document, 
	ElementId^ viewId, 
	LinkElementId^ hostId, 
	XYZ^ point, 
	ElementId^ symbolId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
viewId
Type: Autodesk.Revit.DBElementId
The id of the view in which the symbol should appear.
hostId
Type: Autodesk.Revit.DBLinkElementId
The ElementId of PathReinforcement (either in the document, or linked from another document).
point
Type: Autodesk.Revit.DBXYZ
The span symbol's head position.
symbolId
Type: Autodesk.Revit.DBElementId
The family symbol id of this element.

Return Value

A reference to newly created span symbol.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException hostId should refer to a PathReinforcement element. -or- viewId does not refer to a valid view type for FabricReinSpanSymbol - only floor plan, reflected ceiling plans and elevations are permitted. -or- symbolId should refer to a FamilySymbol of category OST_FabricReinSpanSymbol.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also