Create Method


Path Rein Span Symbol Create Method

Creates a new instance of PathReinSpanSymbol in the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PathReinSpanSymbol Create(
	Document document,
	ElementId viewId,
	LinkElementId hostId,
	XYZ point,
	ElementId symbolId
)

Parameters

document Document
The document.
viewId ElementId
The id of the view in which the symbol should appear.
hostId LinkElementId
The ElementId of PathReinforcement (either in the document, or linked from another document).
point XYZ
The span symbol's head position.
symbolId ElementId
The family symbol id of this element.

Return Value

PathReinSpanSymbol
A reference to newly created span symbol.
Exceptions
Exception Condition
ArgumentException hostId should refer to a PathReinforcement element. -or- viewId does not refer to a valid view type for FabricReinSpanSymbol - only floor plan, reflected ceiling plans and elevations are permitted. -or- symbolId should refer to a FamilySymbol of category OST_FabricReinSpanSymbol.
ArgumentNullException A non-optional argument was null
See Also