Sets the deck embedding type to use for the specified structural deck.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layerIdx
- Type: SystemInt32
Index of a layer in the CompoundStructure.
- embedType
- Type: Autodesk.Revit.DBStructDeckEmbeddingType
The embedding type to be used by the specified layer if it is a structural deck.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The layer is not a structural deck. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration |