SetDeckEmbeddingType Method


Compound Structure Set Deck Embedding Type Method

Sets the deck embedding type to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetDeckEmbeddingType(
	int layerIdx,
	StructDeckEmbeddingType embedType
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.
embedType StructDeckEmbeddingType
The embedding type to be used by the specified layer if it is a structural deck.
Exceptions
Exception Condition
ArgumentException The layer is not a structural deck.
ArgumentOutOfRangeException The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also