GetCurvesInView Method


Gets a collection of curves representing the DatumPlane element in the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public IList<Curve> GetCurvesInView(
	DatumExtentType extentMode,
	View view
)
Visual Basic
Public Function GetCurvesInView ( _
	extentMode As DatumExtentType, _
	view As View _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCurvesInView(
	DatumExtentType extentMode, 
	View^ view
)

Parameters

extentMode
Type: Autodesk.Revit.DBDatumExtentType
The extent type.
view
Type: Autodesk.Revit.DBView
The view.

Return Value

The curves.

Remarks

Curves returned for Model extents can be different than curves returned for View-specific extents (2d extents) in the given view. In some cases, such as an arc grid in a section view, there will be two identical curves but offset from one another.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The datum plane cannot be visible in the view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also