GetCurvesInView Method


Datum Plane Get Curves In View Method

Gets a collection of curves representing the DatumPlane element in the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Curve> GetCurvesInView(
	DatumExtentType extentMode,
	View view
)

Parameters

extentMode DatumExtentType
The extent type.
view View
The view.

Return Value

IList Curve
The curves.
Exceptions
Exception Condition
ArgumentException The datum plane cannot be visible in the view.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
Curves returned for Model extents can be different than curves returned for View-specific extents (2d extents) in the given view. In some cases, such as an arc grid in a section view, there will be two identical curves but offset from one another.
See Also