IsHVACSystemTypeId Method


Checks if given type is valid HVAC system type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static bool IsHVACSystemTypeId(
	Document document,
	ElementId systemTypeId
)
Visual Basic
Public Shared Function IsHVACSystemTypeId ( _
	document As Document, _
	systemTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsHVACSystemTypeId(
	Document^ document, 
	ElementId^ systemTypeId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
systemTypeId
Type: Autodesk.Revit.DBElementId
ElementId of the HVAC system type to check.

Return Value

True if the given systemTypeId is the HVAC system type, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also