GetConditionImage Method


Gets the image for the specified fabrication service button condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016

Syntax

C#
public virtual Bitmap GetConditionImage(
	int condition
)
Visual Basic
Public Overridable Function GetConditionImage ( _
	condition As Integer _
) As Bitmap
Visual C++
public:
virtual Bitmap^ GetConditionImage(
	int condition
)

Parameters

condition
Type: SystemInt32
The condition index.

Return Value

System.Drawing.Bitmap represents the fabrication service button image. a null reference (Nothing in Visual Basic) if there is no preview image.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException the index condition is not larger or equal to 0 and less than ConditionCount

See Also