SetFromRebarShape Method


Set an instance of a RebarContainerItem element, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public void SetFromRebarShape(
	RebarShape rebarShape,
	RebarBarType barType,
	XYZ origin,
	XYZ xVec,
	XYZ yVec
)
Visual Basic
Public Sub SetFromRebarShape ( _
	rebarShape As RebarShape, _
	barType As RebarBarType, _
	origin As XYZ, _
	xVec As XYZ, _
	yVec As XYZ _
)
Visual C++
public:
void SetFromRebarShape(
	RebarShape^ rebarShape, 
	RebarBarType^ barType, 
	XYZ^ origin, 
	XYZ^ xVec, 
	XYZ^ yVec
)

Parameters

rebarShape
Type: Autodesk.Revit.DB.StructureRebarShape
A RebarShape element that defines the shape of the rebar.
barType
Type: Autodesk.Revit.DB.StructureRebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
origin
Type: Autodesk.Revit.DBXYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec
Type: Autodesk.Revit.DBXYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec
Type: Autodesk.Revit.DBXYZ
The y-axis in the shape definition will be mapped to this direction in the project.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The rebarShape has End Treatments
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException xVec has zero length. -or- yVec has zero length.

See Also