SetFromRebarShape Method


Rebar Container Item Set From Rebar Shape Method

Set an instance of a RebarContainerItem element, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFromRebarShape(
	RebarShape rebarShape,
	RebarBarType barType,
	XYZ origin,
	XYZ xVec,
	XYZ yVec
)

Parameters

rebarShape RebarShape
A RebarShape element that defines the shape of the rebar.
barType RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
origin XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec XYZ
The y-axis in the shape definition will be mapped to this direction in the project.
Exceptions
Exception Condition
ArgumentException The rebarShape has End Treatments
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException xVec has zero length. -or- yVec has zero length.
See Also