This class is used to search, filter and iterate through a set of worksets.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
Remarks
Developers can assign a condition to filter the worksets that are returned. If no condition is applied, it attempts to access all the worksets in the document.
The collector will reset if you call another method to extract worksets. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more worksets if you call another method to extract worksets.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBFilteredWorksetCollector
Autodesk.Revit.DBFilteredWorksetCollector