FilteredWorksetCollector Class


Filtered Workset Collector Class

This class is used to search, filter and iterate through a set of worksets.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilteredWorksetCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilteredWorksetCollector : IEnumerable<Workset>, 
	IDisposable

The FilteredWorksetCollector type exposes the following members.

Constructors
Name Description
Public method FilteredWorksetCollector Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FilteredWorksetCollector
Public method FirstWorkset Returns the first workset to pass the filter(s).
Public method FirstWorksetId Returns the id of the first workset to pass the filter(s).
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetWorksetIdIterator Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method GetWorksetIterator Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method OfKind Applies a WorksetKindFilter to the collector.
Public method ToWorksetIds Returns the complete set of workset ids that pass the filter(s).
Public method ToWorksets Returns the complete set of worksets that pass the filter(s).
Public method WherePasses Applies a workset filter to the collector.
Top
Remarks

Developers can assign a condition to filter the worksets that are returned. If no condition is applied, it attempts to access all the worksets in the document.

The collector will reset if you call another method to extract worksets. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more worksets if you call another method to extract worksets.

See Also