Sets a new value for an existing result schema in the result registry
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idx
- Type: SystemInt32
Index of registered result schema
- resultSchema
- Type: Autodesk.Revit.DB.AnalysisAnalysisResultSchema
Result schema replacing the existent one
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | idx refers to non-existent result schema -or- name of resultSchema is not unique in view |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |