Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementFilter
- Type: Autodesk.Revit.DBElementFilter
The ElementFilter containing the rules to check.
Return Value
True if all the parameters of the given rules are valid for this filter, otherwise false.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |