Creates a new instance of Structural Section Flat Bar.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- width
- Type: SystemDouble
Section width.
- height
- Type: SystemDouble
Section height, depth.
- centroidHorizontal
- Type: SystemDouble
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: SystemDouble
Distance from centroid to the upper extremites along vertical axis.
- analysisParams
- Type: Autodesk.Revit.DB.Structure.StructuralSectionsStructuralSectionAnalysisParams
Common set of parameters for structural analysis.