StructuralSectionGeneralF Constructor


Structural Section General F Constructor

Creates a new instance of Structural Section Flat Bar.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralSectionGeneralF(
	double width,
	double height,
	double centroidHorizontal,
	double centroidVertical,
	StructuralSectionAnalysisParams analysisParams
)

Parameters

width Double
Section width.
height Double
Section height, depth.
centroidHorizontal Double
Distance from centroid to the left extremites along horizontal axis.
centroidVertical Double
Distance from centroid to the upper extremites along vertical axis.
analysisParams StructuralSectionAnalysisParams
Common set of parameters for structural analysis.
See Also