GetPointCloudRegionOverrideSettings Method (ElementId)


Gets region override settings assigned to the whole PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public PointCloudOverrideSettings GetPointCloudRegionOverrideSettings(
	ElementId elementId
)
Visual Basic
Public Function GetPointCloudRegionOverrideSettings ( _
	elementId As ElementId _
) As PointCloudOverrideSettings
Visual C++
public:
PointCloudOverrideSettings^ GetPointCloudRegionOverrideSettings(
	ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DBElementId
Id of the overridden element.

Return Value

The override settings assigned to the element, if present, or a default override settings if nothing was found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also