IsLightGroupOn Method


Returns true if the given light group is on

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool IsLightGroupOn(
	ElementId viewId,
	ElementId groupId
)
Visual Basic
Public Function IsLightGroupOn ( _
	viewId As ElementId, _
	groupId As ElementId _
) As Boolean
Visual C++
public:
bool IsLightGroupOn(
	ElementId^ viewId, 
	ElementId^ groupId
)

Parameters

viewId
Type: Autodesk.Revit.DBElementId
The Id of the view
groupId
Type: Autodesk.Revit.DBElementId
The Id of the light group

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light group
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also