Creates a new single-category schedule assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DBElementId
Id of the assembly instance that owns the new view.
- scheduleCategoryId
- Type: Autodesk.Revit.DBElementId
Id of the category for which the schedule will be created. Use ViewSchedule.IsValidCategoryForSchedule() to check if a category can be scheduled.
Return Value
A new single-category schedule assembly view.Remarks
The new single-category schedule will be preloaded with fields "Family and Type" and "Count". The schedule will be empty if there are no elements of the specified category in the assembly instance. The document must be regenerated before using the schedule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- scheduleCategoryId is not a valid category for a regular schedule. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |