CreateSingleCategorySchedule Method


Assembly View Utils Create Single Category Schedule(Document, Element Id, Element Id) Method

Creates a new single-category schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ViewSchedule CreateSingleCategorySchedule(
	Document document,
	ElementId assemblyInstanceId,
	ElementId scheduleCategoryId
)

Parameters

document Document
The document to which the view will be added.
assemblyInstanceId ElementId
Id of the assembly instance that owns the new view.
scheduleCategoryId ElementId
Id of the category for which the schedule will be created. Use ViewSchedule.IsValidCategoryForSchedule() to check if a category can be scheduled.

Return Value

ViewSchedule
A new single-category schedule assembly view.
Exceptions
Exception Condition
ArgumentException assemblyInstanceId is not an AssemblyInstance. -or- scheduleCategoryId is not a valid category for a regular schedule.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
The new single-category schedule will be preloaded with fields "Family and Type" and "Count". The schedule will be empty if there are no elements of the specified category in the assembly instance. The document must be regenerated before using the schedule.
See Also