GetOrCreateWorksharingDisplaySettings Method


Returns the worksharing display settings for the document, creating new settings for the current user if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static WorksharingDisplaySettings GetOrCreateWorksharingDisplaySettings(
	Document doc
)
Visual Basic
Public Shared Function GetOrCreateWorksharingDisplaySettings ( _
	doc As Document _
) As WorksharingDisplaySettings
Visual C++
public:
static WorksharingDisplaySettings^ GetOrCreateWorksharingDisplaySettings(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document of interest.

Return Value

The worksharing display settings for the document.

Remarks

Note that these settings are available even in models that are not workshared. This is to allow pre-configuring the display settings before enabling worksets so that they can be stored in template files.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException doc is not a project document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also