Worksharing |
Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static WorksharingDisplaySettings GetOrCreateWorksharingDisplaySettings(
Document doc
)
Parameters
- doc Document
- The document of interest.
Return Value
WorksharingDisplaySettingsThe worksharing display settings for the document.

Exception | Condition |
---|---|
ArgumentException | doc is not a project document. |
ArgumentNullException | A non-optional argument was null |

Note that these settings are available even in models that are not workshared. This is to allow pre-configuring the display settings before enabling worksets so that they can be stored in template files.