AsValueString Method


Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string AsValueString(
	FamilyParameter familyParameter
)
Visual Basic
Public Function AsValueString ( _
	familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsValueString(
	FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DBFamilyParameter

Return Value

The string that represents the parameter value with unit.

Remarks

The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns a null reference (Nothing in Visual Basic).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument-"familyParameter"-is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown if the input argument-"familyParameter"-is invalid.

See Also