Turns the given light group on or off for rendering the given view depending on the bool argument
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewId
- Type: Autodesk.Revit.DBElementId
The Id of the view
- groupId
- Type: Autodesk.Revit.DBElementId
The Id of the light group
- turnOn
- Type: SystemBoolean
Turns the light group on if true, off if false
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light group |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |