SetLightGroupOn Method


Light Group Manager Set Light Group On Method

Turns the given light group on or off for rendering the given view depending on the bool argument

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLightGroupOn(
	ElementId viewId,
	ElementId groupId,
	bool turnOn
)

Parameters

viewId ElementId
The Id of the view
groupId ElementId
The Id of the light group
turnOn Boolean
Turns the light group on if true, off if false
Exceptions
Exception Condition
ArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light group
ArgumentNullException A non-optional argument was null
See Also