The dot product of this 2-D vector and the specified 2-D vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
- Type: Autodesk.Revit.DBUV
The vector to multiply with this vector.
Return Value
The real number equal to the dot product.Remarks
The dot product is the sum of the respective coordinates of the two vectors: Pu * Ru + Pv * Rv.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when source is a null reference (Nothing in Visual Basic). |