Gets the default family type id with the given family category id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyCategoryId
- Type: Autodesk.Revit.DBElementId
The family category id.
Return Value
The default family type id.Examples

private void AssignDefaultTypeToColumn(Document document, FamilyInstance column)
{
ElementId defaultTypeId = document.GetDefaultFamilyTypeId(new ElementId(BuiltInCategory.OST_StructuralColumns));
if (defaultTypeId != ElementId.InvalidElementId)
{
FamilySymbol defaultType = document.GetElement(defaultTypeId) as FamilySymbol;
if (defaultType != null)
{
column.Symbol = defaultType;
}
}
}

Private Sub AssignDefaultTypeToColumn(document As Document, column As FamilyInstance)
Dim defaultTypeId As ElementId = document.GetDefaultFamilyTypeId(New ElementId(BuiltInCategory.OST_StructuralColumns))
If defaultTypeId <> ElementId.InvalidElementId Then
Dim defaultType As FamilySymbol = TryCast(document.GetElement(defaultTypeId), FamilySymbol)
If defaultType IsNot Nothing Then
column.Symbol = defaultType
End If
End If
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |