GetDefaultFamilyTypeId Method


Document Get Default Family Type Id Method

Gets the default family type id with the given family category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId GetDefaultFamilyTypeId(
	ElementId familyCategoryId
)

Parameters

familyCategoryId ElementId
The family category id.

Return Value

ElementId
The default family type id.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also