SetFluidTypeAndTemperature Method


Sets the fluid type and temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public void SetFluidTypeAndTemperature(
	FabricationService service,
	ElementId fluidId,
	double temperature
)
Visual Basic
Public Sub SetFluidTypeAndTemperature ( _
	service As FabricationService, _
	fluidId As ElementId, _
	temperature As Double _
)
Visual C++
public:
void SetFluidTypeAndTemperature(
	FabricationService^ service, 
	ElementId^ fluidId, 
	double temperature
)

Parameters

service
Type: Autodesk.Revit.DBFabricationService
The fabrication service to be set.
fluidId
Type: Autodesk.Revit.DBElementId
The fluid type id.
temperature
Type: SystemDouble
The temperature in Kelvin.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException fluidId is not a fluid type. -or- The temperature is not defined for the fluidId fluid type.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also