SetFluidTypeAndTemperature Method


Fabrication Service Settings Set Fluid Type And Temperature Method

Sets the fluid type and temperature of the specified service.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFluidTypeAndTemperature(
	FabricationService service,
	ElementId fluidId,
	double temperature
)

Parameters

service FabricationService
The fabrication service to be set.
fluidId ElementId
The fluid type id.
temperature Double
The temperature in Kelvin.
Exceptions
Exception Condition
ArgumentException fluidId is not a fluid type. -or- The temperature is not defined for the fluidId fluid type.
ArgumentNullException A non-optional argument was null
See Also