UpdateSpatialFieldPrimitive Method


Spatial Field Manager Update Spatial Field Primitive Method

Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UpdateSpatialFieldPrimitive(
	int idx,
	FieldDomainPoints fieldDomainPoints,
	FieldValues fieldValues,
	int resultIndex
)

Parameters

idx Int32
Unique index identifying the primitive
fieldDomainPoints FieldDomainPoints
Set of domain points. If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive. If %fieldDomainPoints% is only fieldValues are updated
fieldValues FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
resultIndex Int32
Unique index identifying the result schema
Exceptions
Exception Condition
ArgumentException idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints has inconsistent type -or- resultIndex refers to non-existent result schema
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException fieldDomainPoints and fieldValues have inconsistent number of points
See Also