Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- skyColor
- Type: Autodesk.Revit.DBColor
The top of the sky gradient if the sky is visible.
- horizonColor
- Type: Autodesk.Revit.DBColor
The bottom or the sky gradient if the sky is visible, or the top of the ground gradient otherwise.
- groundColor
- Type: Autodesk.Revit.DBColor
The ground color if the sky is visible (ground shown in uniform color), or the bottom of the ground gradient if the sky is not visible.
Return Value
New background object to pass to View.SetBackground.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |