CreateGradient Method


View Display Background Create Gradient Method

Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ViewDisplayBackground CreateGradient(
	Color skyColor,
	Color horizonColor,
	Color groundColor
)

Parameters

skyColor Color
The top of the sky gradient if the sky is visible.
horizonColor Color
The bottom or the sky gradient if the sky is visible, or the top of the ground gradient otherwise.
groundColor Color
The ground color if the sky is visible (ground shown in uniform color), or the bottom of the ground gradient if the sky is not visible.

Return Value

ViewDisplayBackground
New background object to pass to View.SetBackground .
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also