ElementCategoryFilter Constructor (ElementId, Boolean)


Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public ElementCategoryFilter(
	ElementId categoryId,
	bool inverted
)
Visual Basic
Public Sub New ( _
	categoryId As ElementId, _
	inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
	ElementId^ categoryId, 
	bool inverted
)

Parameters

categoryId
Type: Autodesk.Revit.DBElementId
The category id to match.
inverted
Type: SystemBoolean
True if the filter should match all elements which are not of the given category.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The category was not valid for filtering.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also