ElementCategoryFilter Constructor (ElementId, Boolean)


Element Category Filter(Element Id, Boolean) Constructor

Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementCategoryFilter(
	ElementId categoryId,
	bool inverted
)

Parameters

categoryId ElementId
The category id to match.
inverted Boolean
True if the filter should match all elements which are not of the given category.
Exceptions
Exception Condition
ArgumentException The category was not valid for filtering.
ArgumentNullException A non-optional argument was null
See Also