AddField Method (ScheduleFieldType)


Adds a regular field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public ScheduleField AddField(
	ScheduleFieldType fieldType
)
Visual Basic
Public Function AddField ( _
	fieldType As ScheduleFieldType _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
	ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DBScheduleFieldType
The type of data displayed by the field.

Return Value

The new field.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also