Schedule |
Adds a regular field at the end of the list.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- fieldType ScheduleFieldType
- The type of data displayed by the field.
Return Value
ScheduleFieldThe new field.

Exception | Condition |
---|---|
ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it. |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |