The method used to round values: round to nearest, round up, or round down.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The rounding method. The default is Nearest.Remarks
The RoundingMethod property is currently only supported for rebar parameters. A FormatOptions object containing any rounding method may be returned by Element.GetParameterFormatOptions() and may be passed to the formatting and parsing utilities in the UnitFormatUtils class. FormatOptions objects used in other contexts must contain the default rounding method (Nearest).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | UseDefault is true in this FormatOptions. |