RoundingMethod Property


Format Options Rounding Method Property

The method used to round values: round to nearest, round up, or round down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RoundingMethod RoundingMethod { get; set; }

Property Value

RoundingMethod
The rounding method. The default is Nearest.
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException UseDefault is true in this FormatOptions.
Remarks
The RoundingMethod property is currently only supported for rebar parameters. A FormatOptions object containing any rounding method may be returned by Element.GetParameterFormatOptions() and may be passed to the formatting and parsing utilities in the UnitFormatUtils class. FormatOptions objects used in other contexts must contain the default rounding method (Nearest).
See Also