Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- viewId
- Type: Autodesk.Revit.DBElementId
The view Id.
- curveLoops
- Type: System.Collections.GenericIListCurveLoop
The curve loops to be checked.
Return Value
True if the given curve loops are valid as described above, false otherwise.Remarks
The curve loops are valid if projections of the loops onto the views's detail sketch plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the views's detail sketch plane, but not necessarily the same plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |