IsValidBoundaryOnView Method


Boundary Validation Is Valid Boundary On View Method

Indicates if the given curve loops compose a valid boundary on the view's detail sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidBoundaryOnView(
	Document document,
	ElementId viewId,
	IList<CurveLoop> curveLoops
)

Parameters

document Document
The document.
viewId ElementId
The view Id.
curveLoops IList CurveLoop
The curve loops to be checked.

Return Value

Boolean
True if the given curve loops are valid as described above, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The curve loops are valid if projections of the loops onto the views's detail sketch plane do not intersect each other; each curve loop is closed; input curves do not contain any helical curve; and each loop is planar and lies on a plane parallel to the views's detail sketch plane, but not necessarily the same plane.
See Also