Separate a set of combinable elements out of combinations they currently belong to.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- members
- Type: Autodesk.Revit.DBCombinableElementArray
A list of combinable elements to be separated.
Remarks
If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when members is empty. Thrown when members contains a null reference (Nothing in Visual Basic) elements. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when separation failed. |