SeparateElements Method


Document Separate Elements Method

Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SeparateElements(
	CombinableElementArray members
)

Parameters

members CombinableElementArray
A list of combinable elements to be separated.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument is .
ArgumentException Thrown when members is empty. Thrown when members contains elements.
InvalidOperationException Thrown when separation failed.
Remarks
If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.
See Also