GetShadeConstructionType Method


Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static ElementId GetShadeConstructionType(
	Document ccda,
	ConceptualConstructionShadeType typeEnum
)
Visual Basic
Public Shared Function GetShadeConstructionType ( _
	ccda As Document, _
	typeEnum As ConceptualConstructionShadeType _
) As ElementId
Visual C++
public:
static ElementId^ GetShadeConstructionType(
	Document^ ccda, 
	ConceptualConstructionShadeType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DBDocument
The Document.
typeEnum
Type: Autodesk.Revit.DB.AnalysisConceptualConstructionShadeType
The ConceptualConstructionShadeType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The enum is invalid for ConceptualConstructionShadeType. -or- A value passed for an enumeration argument is not a member of that enumeration

See Also