Conceptual |
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ElementId GetShadeConstructionType(
Document ccda,
ConceptualConstructionShadeType typeEnum
)
Parameters
- ccda Document
- The Document.
- typeEnum ConceptualConstructionShadeType
- The ConceptualConstructionShadeType to get the ConceptualConstructionType for.
Return Value
ElementIdReturns ElementId of a ConceptualConstructionType.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionShadeType. -or- A value passed for an enumeration argument is not a member of that enumeration |