Returns the active pre-defined non-in-session exporting settings for DGN in the given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DBDocument
A Revit document to retrieve the active pre-defined exporting settings for DGN.
Return Value
The active pre-defined exporting settings for DGN, or null if nothing pre-defined exists or the in-session settings is selected.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |