GetExportLinetypeInfo Method


Gets a copy of the ExportLinetypeInfo corresponding to the given ExportLinetypeKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLinetypeInfo GetExportLinetypeInfo(
	ExportLinetypeKey exportLinetypeKey
)
Visual Basic
Public Function GetExportLinetypeInfo ( _
	exportLinetypeKey As ExportLinetypeKey _
) As ExportLinetypeInfo
Visual C++
public:
ExportLinetypeInfo^ GetExportLinetypeInfo(
	ExportLinetypeKey^ exportLinetypeKey
)

Parameters

exportLinetypeKey
Type: Autodesk.Revit.DBExportLinetypeKey
The export line type Key.

Return Value

Returns the line type info for this key.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException An entry with the given key is not present in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also